
 

2008 

2008 April 

GPS Data Logger User’s Manual 



 

Contents 
Read GPS Log From Device ...................................................................................................................... 3 

Clear Data Logger Memory ...................................................................................................................... 4 

Data Logger Configuration ....................................................................................................................... 5 

Track List Window ................................................................................................................................... 7 

Add Place Mark ....................................................................................................................................... 8 

Add Photos .............................................................................................................................................. 9 

Browse photos ...................................................................................................................................... 10 

GeoTag – Save GPS Information into Photos .......................................................................................... 10 

Photo List Window ................................................................................................................................ 11 

Upload Photos to Flickr ......................................................................................................................... 11 

Shift Photo Time .................................................................................................................................... 12 

Photo Comments................................................................................................................................... 13 

Media List View ..................................................................................................................................... 13 

Google Earth Viewing ............................................................................................................................ 14 

Save As KMZ File .................................................................................................................................... 14 

Altitude Graph ....................................................................................................................................... 14 

Speed graph .......................................................................................................................................... 15 

Track Editing .......................................................................................................................................... 15 

Save and Open Project .......................................................................................................................... 18 

Time Zone Setting ................................................................................................................................. 18 

Options ................................................................................................................................................. 19 

 



 

Read GPS Log From Device 

Step 1 – Connect Data Logger to PC USB port. Please make sure the Data 

Logger power is turn on. 

Step 2 – Menu command “File” -> “Read log…” Users have to input product 

key at the first time. The product key is on the cover of installation CD. 

 

GPS Photo Tagger will automatically detect the port and baud rate and read in 

the GPS tracks. 

 

A track list window will be popped up. Select the tracks to import. 



 

Tracks will be shown on the Google Map window.  

 

Clear Data Logger Memory 

Menu command “File” -> “Clear log” will clear the data stored in device, so the 

device memory are enough for next usage. 



 

Data Logger Configuration 

Connect Data Logger to PC and turn on Data Logger. Menu command “File” -> 

“Config GPS…” If Data Logger is not connected, the GPS Log Setting area will be 

disabled. Please make sure the Data Logger power switch is turn on when connect. 

 

Connection Setting: 



Auto Scan GPS Module (Recommended) 

The program will automatically detect the com port and the baud rate. It is 

recommended to set to auto scan. 

Manual Setting 

Users can also manually set the port and baud rate. Although it can speed up the initial 

connect time, but it is not recommended unless users understand the valid port and 

baud rate. 

Reset Device 

Reset the GPS device when the behavior is abnormal. 

 

GPS Log Setting 

There are 4 log modes: General mode, vehicle mode, cycling mode, and 

hiking mode. Users can also change the default setting of these 4 modes. 

Log every () seconds: 

Specify the log period. For example, if specify 3 seconds, the GPS device will log 

every 3 seconds. 

Log every () meters: 

Specify the log distance. For example, if specify 10 meters, the GPS device will 

log every 10 meters. 

Log over () km/h: 

Specify the log speed. For example, if specify 20 km/h, the GPS device will log 

when the speed is over 20 km/h. 

Note: GPS device will log only when the log period, log distance, and log speed all meet 

the criteria. 

Data Log Memory 

A bar show how many percentage of memory is used in the Data Logger 

device. Users can use “Clear Log” to clear all the memory. 



When data logger memory is full 

Overwrite:  Overwrite the earliest logged data. 

Stop Log: Stop data logging. 

Track List Window 

Tracks are list on the top. Users can change the colors and line widths of tracks. 

Press “Play” button, Google map window will animate the whole trip by moving the current position. 

Check “Photo Slide Show” will show photo while animate trips. 

 



Add Place Mark 

 

To add a new place mark, please click on the blue balloon icon, and then 

click on the position of new place marker. The “Place Mark Property” dialog 

will be pop up for editing. 

 

Users can manually add photos to the place mark, or delete photos from 

the place mark.  

 



 

Add Photos 

Users can add photo from a file folder, or selected files. 

Add photo from a folder: Menu command “Photo” -> “Add Photo…” -> 

“From Folder”. Select a folder to add photo. 

Add photo from selected files: Menu command “Photo” -> “Add Photo…” -> 

“From Files”. Use Ctrl-Click, or Shift-Click to select multiple files. 

The photo will show on the Photo View window. Users can add comments 

to each photo. Users can also rotate, delete photo. 

 

When photos are added, GPS Photo Tagger will automatically match photo 

and GPS logged waypoints by time. Place marks will be created as a 

placeholder for photos. 

  



Browse photos 

Click on the “next photo” and “prev photo” buttons to browse the photos. 

Current photo and current place mark will be synchronized. 

 

GeoTag – Save GPS Information into Photos 

Menu command “Photo” -> “Write GPS info into photos” will save the 

latitude, longitude, and altitude into photo. 

A progress window will show the writing progress. 

 

Synchronized 



Photo List Window 

Photo list window will show the attributes of photos. The information includes 

“file name”, “date”, “place mark”, “latitude”, “longitude”, and “Geotagged 

flag”. 

 

Upload Photos to Flickr 

Menu command “Photo” > “Upload Photos to Flickr…” will invoke upload 

wizard. Users can set “Title”, “description”, “Tag”, “Public or Private”, and 

“Upload photo size”. 



 

If you want to upload geotagged photos directly on Flickr web site: 

You have to turn on the following option. "Your Account">"Privacy & 

Permissions">"Import EXIF location data: Yes" 

After the option is turned on, the uploaded photo will be put on map. 

Go to Flickr > “You” > “Your map”, you can browse your photos on the map. 

Shift Photo Time 

Menu command “Photo” -> “Shift photo time…” will invoke the shift photo 

time window. All the photo will be added (or subtracted) the specified time. 

The dates are saved in the Exif parts of Jpeg or Tiff file. After the shift, GPS 

Photo Tagger will automatically match the photo and track waypoints again. 

User can put more than 365  in days. 

 



Photo Comments 

Support multi-language comments. The comments will be uploaded to Flickr, 

packed in the kml file. 

Media List View 

Users can import not only photos. All other media files are allowed to be 

imported and tagged to tracks according to the file create times. 

 

 



Google Earth Viewing 

Command “File” -> “View in Google Earth” will invoke Google Earth to view 

the tracks and photos. Users have to install the Google earth. 

http://earth.google.com/ 

 

Save As KMZ File 

Menu command “File” -> “Export as Kmz…” to save the tracks and photos in 

kmz file. You can import kmz file to Google Earth. You can also send kmz file to 

friends to share their trips with friends as long as they have installed Google 

Earth on their computers. 

The picture size packed in the kmz file can be set in the options dialog. Menu 

command “Tools” -> “Options” > “Google Earth” > “Photo size in KMZ”. 

Altitude Graph 

Switch to “Altitude View” window will show the altitude graph. The waypoints 

with photos on it will be marked with red square. Moving cursor on red square 

will display the photo. You can pan left, pan right, zoom in, zoom out in the 

altitude graph. 



Speed graph 

Switch to “Speed View” window will show the speed graph. The waypoints with 

photos on it will be marked with red square. Moving cursor on red square will 

display the photo. You can pan left, pan right, zoom in, zoom out in the altitude 

graph. 

 

Track Editing 

Switch to folder “Track Editor” on the left window. Move the cursor on the 

track will show the preselected waypoint time. Click on track to select the 

whole track. 



 

 

- Shift-Click multiple selections 

Select one waypoint, and then shift-click on another waypoints. The 

waypoints between these two waypoints will all be selected. 

- Ctrl-Click multiple selections 

Ctrl-Click on waypoints will toggle the waypoints selections. 

- Area selection 

Click on “Area Selection”button, drag an rectangle area. All the 

waypoints and place marks in the rectangle area will be selected. 

- Delete waypoints 

Click on “Remove” button to remove the selected objects. 

- Split tracks 

Click on a waypoint, and click right mouse button. Select command 

“Split Track”.  

 



- Merge tracks 

Command “Track” > “Merge Tracks”. 

Select the tracks. Press OK button. 

 

 

- Undo/Redo 

press “undo” “redo” buttons to undo/redo the edit actions. Multiple 

layers of undo/redo are suppoted. 

 



Save and Open Project 

Menu command “File” -> “Save project” will save the tracks and photo as a 

project file. 

Menu command “File” -> “Open project…” will open the saved project. The 

project, photos, and photo comments will be restored after the project 

opened. 

Time Zone Setting 

There are two time zone settings in “GPS Photo Tagger”. One is “Photo time 

zone”, the other is “Display time zone”. “Photo time zone” is set to the same 

time zone of your digital camera. The “Display time zone” is set for displaying 

purpose. For example, If you are an Englishman and you travel to United State. 

The “Photo time zone” should be set to “England” because your digital camera 

time zone is in England, and the display time zone should be set to “United 

State”. 

The “Photo time zone” by default is set to the PC default value. In most of the 

case the default value is correct. 

Menu command “Tools” -> “Options” will invoke the options dialog. You can 

set “Photo Time Zone” in the dialog. 



 

The “display time zone” setting is in the status bar. 

 

Options 

Menu command “Tools” > “Options…” 



 

Distance unit: 

Metric: Kilometer / meters will be used for displaying. 

Imperial: Miles / feet will be used for displaying. 

Lat/Long: 

Degrees, minutes, seconds: Latitude and longitude will be display like 23°12’20” 

Degrees: Latitude and longitude will be display like 23.22152°  

Photo Time Zone:  

The time zone of your digital camera time setting 

Max photo/track diff time:  



The setting is used to match photo and track waypoints. Photo Tagger will match photos 

and waypoints by time. It will find the nearest waypoint time to locate the photo. Yet, if 

the closest waypoint time is more than the “Max photo/track diff time”, it will not 

match the photo. 

Group Photos when distance is less than: 

When two photos’ distance is less than the setting, these two photos will be put in the 

same place mark. 

Photo size in KMZ:  

The size of the photos packed in the KMZ file. It is related to the command “File” > 

“Export As KMZ…” 

Preferred Language: 

 Set the languages for menu, buttons and messages. 


